Banished Ventures

Crash related to Forester Lodge

Home Forums Bug Reports Crash related to Forester Lodge

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #6062
    masterk
    Participant

    Hi! First of all, thank you for an awsome mod!

    I’ve started a new game after 7.1 was released. After getting access to glass, I built a forester lodge, and the game crashed soon thereafter, with an “Access violation” message. I had several more crashes, and after a bit of testing I believe I have nailed down the conditions:

    – Bogland within the lodge’s work radius, with at least one tree nestled in it
    – The lodge’s “Cut”-job enabled, and workers assigned.
    The game doesn’t crash if only “Plant” is selected.

    I also started a new map, and confirmed it was happening there as well, using a debug mod to place the lodge straight away.
    I also noticed that the workers assigned to the lodge appear to remove other resources from the map when no trees is available, including removing bogland, mining stone and iron… Maybe this is related.

    Again, thank you for this awsome mod, let me know if I can help you test this crash further!
    Brg Martin

    #6063
    Tom SawyerTom Sawyer
    Participant

    What a terrible bug. Thank you for this report and for narrowing it down to the forester!

    It is now fixed and updated. I made lot of tests with foresters in bogland and did not get a crash anymore. Foresters do not try to remove bogland anymore and if a tree is completely nested in a bog, they ignore (can’t reach) it. This way you also don’t loose peat anymore because of all too ambitious foresters.

    I tested it also with a save game from April 24 and it worked. So you can just update the mod and continue your game.

    #6064
    masterk
    Participant

    Wow. You fixed that amazingly quickly! It seems to work here as well.
    I’m glad I could help, and thank you again for this amazing mod :-D.

    #6067
    taganaya
    Participant

    Huh. That might have been the issue with that game of mine that crashed with that same error which I couldn’t find a pattern to. Good catch.

    #6068
    Tom SawyerTom Sawyer
    Participant

    It was very likely the same problem. I’ve loaded your save game with the fixed version and had no crashes anymore.

    #6191
    OldSock
    Participant

    I’m getting crashes, and it seems like it’s this bug. I am using North 711(1.07).

    The crashes started happening when I built a Forester lodge near some peatland and staffed it. As long as I keep “cut” turned off the crashes stop.

    #6192
    Tom SawyerTom Sawyer
    Participant

    I was looking into it and this known bug of the forester went into 7.1.1 again because I took the folder from 24.04. for creating the Steam version. Now I uploaded 7.1.2 here on website and on Steam to fix it once more. This update is save game compatible.

    Thank you very much for your report!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.